SD Card not working

Started by Bbarkhurst, October 16, 2016, 23:06:52

Previous topic - Next topic


SD Card not working for me.

It shows something like "error loading xml file javalang null pointer exception attempt to invoke virtual method io java input stream byte [] on null object reference.   

Then it fell back to demo mode that works. Also so you know it is working fine no problem with oculus home not over running it, which is did on the older version but since I did 0.30 no issue.  Also note that the xml that you are hosting is loading fine and it works as well.

I tried to load a new local tour to the SD Card after generating.  I tried to follow what I know to do.

1. Folder is on route of SD Card as VRTourweaver. 
2. Therein it has these files:
index.html pano.xml pano2vr_player.js pano2vrgyro.js and skin.js.  Subfolder is images that contains cube faces, though there seems to be a black and white preview lower res file for each and file names. 

There are no "tiles folders."

It may be something with the way I generated it form pano2vr though I tried to just go back to default and start over making only the changes in your post on pano2vr site.

Version 0.30

Starting with 4 new nodes. had it working in pano2vr.

In output, added second output stare.ggsk. Html set to html file cardboard.ggt with the tools set to Image set to smooth interporlation which was default and non stereo as it wasnt and embedded xml turned off.  Image set to single res 1536px.  So I think I did everything required. Let me know if you need the package file or what.

Ruud van Reenen

Thanks for the report!

According to your description your output should be ok. Can you send me a zip file with the entire content of the VRTourviewer folder from your sdcard? Then I can try to replicate it here.

Email: ruud@vrtourviewer.com
If the zip-file is too large for email, please use WeTransfer.

Ruud van Reenen

It might be a typo in your post only, but make sure the folder on your sdcard is called 'VRTourviewer' and not 'VRTourweaver'.


Post typo only. It is in \VRTourviewer

First three letters capitalized only as specified.

In my files it shows on root of sd card on my Galaxy s6 edge phone. I do note on the es file explorer app  i also see the path has some numbers in it and it reads
storage \ 2134-287e \ VRTourviewer

.   An Android thing i believe.have had issues with good sync before adressing sd cards on various android devices. ??

It reads normal in (my files) app that came with the phone. What next?

Ruud van Reenen

I've received the zip file with your local tour, unpacked it and moved the content to my Galaxy S6 sdcard folder 'VRTourviewer'. Attached a screenshot of the contents of the folder.

This local tour works fine here with build 30.
The error you are seeing means the app can't find the file pano.xml in the VRTourviewer folder. In the next build I'll add some more explanatory error messages when this happens.

Can you doublecheck that the tour content and the file pano.xml is directly in the folder VRTourviewer on the root of the sdcard? And not inside another folder called VRTourviewer for example.

BTW: When I view the content of my sdcard with ES File Explorer (from the apps Homepage, click the big diskette icon) the sdcard shows for me as 'emulated/0', but I'm not sure if that matters. Do you have multiple sdcards in your phone (if that is even possible with S6)?


Thanks for the screen shot you sent! It actually seems to show the phone is where you have it going on your end, and not the card, at least as viewed from windows PC?  I created a folder in that same location and it fired up and WORKED! deleted the SD card folder still working!

The Galaxy S6 has only one SD slot of course. Not sure where that name came from that my ES shows - perhaps a volume label at sd initialization? though I didn't assign it or remember it coming up.  There seems to be a lot of confusion on SD cards and android including different versions of Android - beyond my level of knowledge - googling I found similar things such as the following... not sure what all it is about, perhaps you will.  http://android.stackexchange.com/questions/39542/confused-by-the-many-locations-of-the-virtual-sdcard

As I said it is working when I make the \VRTourviewer from windows PC on the root of the phone, or at least what appears to be the phone's root according to Windows USB access, and NOT on the SD card, as it seems you intended perhaps.

On the tour itself,  I was excited to see it working nicely and the lense flairs add a nice effect.  I did notice, it does seems to ignore when jumping to a pano the starting view points I had set, and also the starting viewpoint of first pano I set - it seems to take a mid point or a certain cube face and that's it (about middle of source pano).

Could you give us a way to select subfolders under that \VRTourviewer, ideally on SD versus main phone but either is ok for now?  That would allow a simple menu construct and let us also see the path info more clearly.

Ruud van Reenen

Oh wow! Thanks for pointing that out, you are so right, the location was indeed on the phone instead of the external sdcard...
Sorry for the (my) confusion!

Initial view/rotation of panoramas will be added soon.

A submenu to choose from or browse local tours will be added too. I think it should list all xml files in the VRTourviewer folder and subfolders and show sub/foldername and filename.


I also have found that the offline tour will NOT work on the SD card in the required folder.. correctly named... on my file explorer I see PHONE and CARD ... not "sdcard" .. Could the app be looking in the wrong place?

Ruud van Reenen

I think you're right. I suspect you're using a Samsung Galaxy S7 or S7 edge?
Unfortunately I only have an S6 for testing and it doesn't have an actual external sdcard.
Can you see a folder VRTourviewer in the 'PHONE' and try copying a tour to that folder to see if it works?

I'll upload a new build today that can hopefully detect the external sdcard on S7/S7 Edge.

Ruud van Reenen

Build 41 contains some more debugging info and a new function to determine sdcard location for an S7 or S7 Edge.


Please let me know if it works.